Subject: Re: [boost] [gsoc][RFC] Pointer Plus Bits
From: Stefan Strasser (strasser_at_[hidden])
Date: 2010-07-27 11:27:23
Zitat von "Stewart, Robert" <Robert.Stewart_at_[hidden]>:
>> One of the other names which came up for this data structure
>> was bit_tuple does that sound any better?
> I don't think that's good. It isn't a tuple of bits, but rather of
> arbitrarily grouped bits. Hence "bit_field_tuple" is the better name.
there is no reason to be strict with the naming here. even if it's
technically two words, there's boost::dynamic_bitset, std::bitset and
maybe other examples.
(regarding the underscore. I agree wrt to a bitfield tuple not being a
tuple of bits)