Boost logo

Boost :

Subject: Re: [boost] [constrained_value] Constrained Value review results
From: Krzysztof Czainski (1czajnik_at_[hidden])
Date: 2010-10-07 06:52:11

2010/10/7 Robert Kawulak <robert.kawulak_at_[hidden]>

> bounded<int> // bounds specified at runtime
> bounded_ct<int, 0, 10> // bounds specified as compile time constants

Personally, I like bounded_ct. The abbreviation CT corresponds RT (run
time), which is commonly used.

> Maybe even "c" alone would suffice?

In my opinion suffix _c does not suffice, because it reminds me of const. If
I remember correctly, in MPL the _c suffix does mean const. Therefore I vote
for _ct.


Boost list run by bdawes at, gregod at, cpdaniel at, john at