Boost logo

Boost :

Subject: Re: [boost] [constrained_value] Constrained Value review results
From: Stewart, Robert (Robert.Stewart_at_[hidden])
Date: 2010-10-07 07:46:28

Krzysztof Czainski wrote:
> 2010/10/7 Robert Kawulak <robert.kawulak_at_[hidden]>
> > bounded<int> // bounds specified at runtime
> > bounded_ct<int, 0, 10> // bounds specified as compile time constants
> Personally, I like bounded_ct. The abbreviation CT corresponds RT (run
> time), which is commonly used.

My suggestion was to make "ct" a prefix akin to "static_" in static_cast and static_assert. I do like the parallel with "rt," so I would prefer these:


Those have the advantage of being readable in English: "compile time bounded int" and "runtime bounded short." With familiarity, I imagine that "compile time" and "runtime" would be reduced to "see tee" and "arr tee."

Rob Stewart robert.stewart_at_[hidden]
Software Engineer, Core Software using std::disclaimer;
Susquehanna International Group, LLP

IMPORTANT: The information contained in this email and/or its attachments is confidential. If you are not the intended recipient, please notify the sender immediately by reply and immediately delete this message and all its attachments. Any review, use, reproduction, disclosure or dissemination of this message or any attachment by an unintended recipient is strictly prohibited. Neither this message nor any attachment is intended as or should be construed as an offer, solicitation or recommendation to buy or sell any security or other financial instrument. Neither the sender, his or her employer nor any of their respective affiliates makes any warranties as to the completeness or accuracy of any of the information contained herein or that this message or any of its attachments is free of viruses.

Boost list run by bdawes at, gregod at, cpdaniel at, john at