Boost logo

Boost :

Subject: Re: [boost] [constrained_value] Constrained Value review results
From: Krzysztof Czainski (1czajnik_at_[hidden])
Date: 2010-10-07 08:09:17

2010/10/7 Stewart, Robert <Robert.Stewart_at_[hidden]>

> My suggestion was to make "ct" a prefix akin to "static_" in static_cast
> and static_assert. I do like the parallel with "rt," so I would prefer
> these:
> rt_bounded<short>

I second the suggestion for "ct" in favour of "static" for two reasons: it
is shorter, and static has its other meaning.

Those have the advantage of being readable in English: "compile time bounded
> int" and "runtime bounded short." With familiarity, I imagine that "compile
> time" and "runtime" would be reduced to "see tee" and "arr tee."

I prefere sufexes, becaluse then the part of the name, that brings most
information comes first:

bounded_ct<int> x; // bounded at compile time of type int
bounded<int> x; // bounded (at run time) of type int


Boost list run by bdawes at, gregod at, cpdaniel at, john at