Boost logo

Boost :

Subject: Re: [boost] [constrained_value] Constrained Value review results
From: Robert Kawulak (robert.kawulak_at_[hidden])
Date: 2010-10-07 08:59:43

2010/10/7 Stewart, Robert <Robert.Stewart_at_[hidden]>:
>> > instead of "bounded," use "bound," "bounds,"
>> Using "bound" or "bounds" seems misleading to me. The object
>> represented by the type is a bounded value, not value of the bounds.
> I was using "bound" as a verb in those cases: "ct_bound" means bound at compile time.  According to,
> "bound" as a noun is usually in the plural, so I didn't confuse "bound" as a noun in my suggestions, though I can see how others might.

You mean "bound" as past participle of "to bind", so "ct_bound" would
mean something that has been bound (i.e., "binded") at compile time? I
think the operation we want to express is bounding rather than

> My suggestion was to make "ct" a prefix akin to "static_" in static_cast and static_assert.  I do like the parallel with "rt," so I would prefer these:
>   ct_bounded<int>
>   rt_bounded<short>

The former is the subset of the latter, so "rt_bounded" is not a good
idea since it may represent objects with compile-time-fixed bounds as
well. I think just "bounded" is the best.

2010/10/7 Krzysztof Czainski <1czajnik_at_[hidden]>:
> I prefere sufexes, becaluse then the part of the name, that brings most
> information comes first:
> bounded_ct<int> x; // bounded at compile time of type int
> bounded<int> x; // bounded (at run time) of type int

I agree with you for the same reason. Moreover, if you start typing
"boun..." in an IDE, its autocomplete will show both the options, so
it has a small productivity advantage too. ;-)

Best regards,

Boost list run by bdawes at, gregod at, cpdaniel at, john at