Subject: Re: [boost] Boost Evolution
From: Simonson, Lucanus J (lucanus.j.simonson_at_[hidden])
Date: 2010-10-08 16:25:13
>> I'm somewhat confused about "detail". If it's an implemenation
>> of a particular library it should be in that library.
> +1, and I this that the name space should be prefixed by the name of
> the library as ratio::ratio_detail.
Why? boost::ratio::detail is distinct from boost::polygon::detail and unambiguously so. Namespace is the preferred style option to naming convention with prefixes to prevent ambiguity/collisions, I see no reason to use both.
Boost list run by bdawes at acm.org, gregod at cs.rpi.edu, cpdaniel at pacbell.net, john at johnmaddock.co.uk