Boost logo

Boost :

Subject: Re: [boost] Boost Evolution
From: vicente.botet (vicente.botet_at_[hidden])
Date: 2010-10-08 17:21:00

----- Original Message -----
From: "Simonson, Lucanus J" <lucanus.j.simonson_at_[hidden]>
To: <boost_at_[hidden]>
Sent: Friday, October 08, 2010 10:25 PM
Subject: Re: [boost] Boost Evolution

> vicente.botet wrote:
>>> I'm somewhat confused about "detail". If it's an implemenation
>>> detail
>>> of a particular library it should be in that library.
>> +1, and I this that the name space should be prefixed by the name of
>> the library as ratio::ratio_detail.
> Why? boost::ratio::detail is distinct from boost::polygon::detail and unambiguously so. Namespace is the preferred style option to naming convention with prefixes to prevent ambiguity/collisions, I see no reason to use both.

To ensure unabiguous behavior, I will need to use on the Boost.Ratio code ratio::detail, which is quite close to ratio_detail. The advantage of the last is that it avoid the direct use of detail which could be ambiguous.


Boost list run by bdawes at, gregod at, cpdaniel at, john at