Boost logo

Boost :

Subject: Re: [boost] review request: addition to type_traits library ofhas_operator_xxx
From: Edward Diener (eldiener_at_[hidden])
Date: 2010-11-20 12:11:14

On 11/20/2010 10:48 AM, Frédéric Bron wrote:
>>> * I'm not that keen on the operators:: subnamespace, to me that
>>> namespace is reserved for the operators library
>>> it would
>>> have to be boost::type_traits::operators I guess which is rather less
>>> cute :-(
>> I forgot about this when I made my suggestion. I myself would not find
>> boost::type_traits::operators to be too onerous, since after all one could
>> alias the namespace as one likes, but I am a much stronger proponent of
>> clarity in reading code than how much I have to type and many others seem to
>> find important how many letters they have to type to use something in their
>> code.
> So how do we decide for one or the other solution. What would be the
> way to decide?
> As far as I am concerned, I have no strong opinion. The namespace
> solution looks clearer but I like short typing too...
> Do we need to organize sort of a vote?

It is ultimately your decision. No matter which way you decide there
will always be people who will like it and those who will not.

Boost list run by bdawes at, gregod at, cpdaniel at, john at