Subject: [boost] Boost.Conversion: functors namming
From: Vicente BOTET (vicente.botet_at_[hidden])
Date: 2011-05-15 05:40:21
during the Boost.Convert after review discussion there were some proposals to use Boost.Phoenix to build the functors.
My question is what should be the name of the function that builds the functor. Some possibilities:
A- Use a different name: make_converter_to?
B- Use the same name in a different namespace. What about using "fp" as namespace (functional programming).
C- Use the same name in the same namespace and use SFINAE/enable_if to select the correct implementation depending on the parameter.
Which are your preferences?
Boost list run by bdawes at acm.org, gregod at cs.rpi.edu, cpdaniel at pacbell.net, john at johnmaddock.co.uk