Subject: Re: [boost] [lockfree review] rfc: naming and interface
From: Klaim - JoÃ«l Lamotte (mjklaim_at_[hidden])
Date: 2011-07-21 07:15:52
On Thu, Jul 21, 2011 at 11:58, Joshua Juran <jjuran_at_[hidden]> wrote:
> As for "ringbuffer", I would consider shortening it to just "ring".
I'm not sure if ringbuffer share exactly the same concepts than
boost::circular_buffer but to be consistent with this library naming maybe
ringbuffer should be circular_buffer?
I prefer "ring" alone personnally but as circular_buffer have been accepted
before maybe it's naming is more explicit to a lot of reviewers?
Boost list run by bdawes at acm.org, gregod at cs.rpi.edu, cpdaniel at pacbell.net, john at johnmaddock.co.uk