Subject: Re: [boost] Formal Review Request: TypeErasure (docs, Concept Maps misnamed?)
From: Robert Ramey (ramey_at_[hidden])
Date: 2012-06-21 12:45:01
Steven Watanabe wrote:
> On 06/21/2012 07:16 AM, Larry Evans wrote:
>> On 05/22/12 15:34, Steven Watanabe wrote:
>>> I'd like to request a formal review of the
>>> TypeErasure library that I've posted about
>>> several times before here.
>>> Online documentation can be found here:
>> The page:
>> with section title, "Concept Maps", seems to be about
>> specializing a builtin concept. I don't see anything
>> in that section about a map.
> a) This applies to any concept, not just
> builtin ones.
> b) "Concept Map" is the concept term for
FWIW - Personally I've always found the word "concept" used in this context
extremely unexpressive and misleading. I believe that this naming has
this extremely useful idea from spreading as far within the C++ community
as it deserves to be.
Maybe we should start referring to this idea as "Type Requirements". I
figured out what "concept map" is supposed to mean. Maybe you've cleared
that up for me. Maybe it should be referred to "Type Requirement
> In Christ,
> Steven Watanabe
> Unsubscribe & other changes:
Boost list run by bdawes at acm.org, gregod at cs.rpi.edu, cpdaniel at pacbell.net, john at johnmaddock.co.uk