Boost logo

Boost :

Subject: Re: [boost] [config] Add BOOST_NO_RANGE_BASED_FOR macro?
From: Marshall Clow (mclow.lists_at_[hidden])
Date: 2012-07-09 11:54:25


On Jul 9, 2012, at 8:19 AM, Beman Dawes wrote:

> I'm about to add Boost.Filesystem support for C ++11 range-based for
> statements, and would like to include direct test cases for compilers
> that have the feature.
>
> Is it OK to add a BOOST_NO_RANGE_BASED_FOR macro to trunk?

Two options:
1) Can you just test for c++11 support? Range based for loops are pretty basic
#if __cplusplus >= 201103L

2) If you have to add a config flag, please match the CXX11 naming scheme and call it something like
BOOST_NO_CXX11_RANGE_BASED_FOR

-- Marshall

Marshall Clow Idio Software <mailto:mclow.lists_at_[hidden]>

A.D. 1517: Martin Luther nails his 95 Theses to the church door and is promptly moderated down to (-1, Flamebait).
        -- Yu Suzuki


Boost list run by bdawes at acm.org, gregod at cs.rpi.edu, cpdaniel at pacbell.net, john at johnmaddock.co.uk