Subject: Re: [boost] [config] Add BOOST_NO_RANGE_BASED_FOR macro?
From: Marshall Clow (mclow.lists_at_[hidden])
Date: 2012-07-09 14:37:30
On Jul 9, 2012, at 11:28 AM, Beman Dawes wrote:
>> 2) If you have to add a config flag, please match the CXX11 naming scheme and call it something like
> We are using the BOOST_NO_CXX11_ scheme for header files only. None of
> the 28 feature macros we already have use a BOOST_NO_CXX11_ prefix.
Well, shame on us.
I could argue about
but those are "related to" header files.
IM(NS)HO, these should all be BOOST_NO_CXX11 macros.
For example, BOOST_NO_NULLPTR should be BOOST_NO_CXX11_NULLPTR
(but we're not going to change that today)
Marshall Clow Idio Software <mailto:mclow.lists_at_[hidden]>
A.D. 1517: Martin Luther nails his 95 Theses to the church door and is promptly moderated down to (-1, Flamebait).
-- Yu Suzuki