Subject: Re: [boost] [gil::io] Feedback for scanline_read_iterator
From: Christian Henning (chhenning_at_[hidden])
Date: 2013-02-21 09:41:11
> I don't particularly love the class name.
> An istream_iterator iterates over the elements of the stream.
> A directory_iterator iterates over the contents of a directory.
> A vector::iterator iterates over the elements of the vector.
> A scanline_read_iterator iterates over the scanlines of an image.
> One might reasonably expect a scanline_read_iterator to iterate over the
> elements of a scanline.
> I could be wrong and I don't really have a better name aside from maybe
> scanline_reader::iterator. (reader_t::iterator in your example code)
> Also scanline_read_iterator.hpp is in the detail folder. If this class isn't
> meant for public consumption completely ignore my naming concerns.
Thanks a lot for your insight! I hope I'll some time tonight to
address all your points.
Boost list run by bdawes at acm.org, gregod at cs.rpi.edu, cpdaniel at pacbell.net, john at johnmaddock.co.uk