Boost logo

Boost :

Subject: Re: [boost] [thread] synchronized_value: value and move semantics
From: Bjorn Reese (breese_at_[hidden])
Date: 2013-06-27 03:49:32

On 06/26/2013 09:56 PM, Andrey Semashev wrote:

> 4. Could synchronized_value be renamed to just synchronized? Besides being
> shorter, this naming seems to be aligned with optional and reads more
> naturally. Consider:
> optional< int > oi;
> synchronized< queue< int > > sqi;

And the synchronize() function could be renamed to hold() to make the
names more discernible.

Boost list run by bdawes at, gregod at, cpdaniel at, john at