Subject: Re: [boost] [multiprecision] Radix-2 typedef naming convention
From: John Maddock (john_at_[hidden])
Date: 2013-11-01 08:15:19
>> In John's new radix-2 MP back end, names are used for
>> common types such as:
>> float24_t, float53_t, float113_t.
>> In our proposal for floating-point typedef's having
>> specified widths, we use names such as:
>> float32_t, float64_t, float128_t.
>> Both conventions make sense in sensible ways.
>> But only one naming convention should be used,
>> and it should be used consistently.
>> Which one will it be?
> I think float32_t, float64_t, float128_t are better since they describe
> size of the type and are aligned with integer typedefs.
That was my thought, although note that in the case of the
Boost.Multiprecision types these are emulations of those hardware types and
are not actually 32, 64 or 128 bits in size. And evn in hardware, an 80-bit
extended real may actually occupy 128 bits in memory...
Boost list run by bdawes at acm.org, gregod at cs.rpi.edu, cpdaniel at pacbell.net, john at johnmaddock.co.uk