Subject: Re: [boost] [multiprecision] Radix-2 typedef naming convention
From: Andrey Semashev (andrey.semashev_at_[hidden])
Date: 2013-11-01 07:41:32
On Friday 01 November 2013 11:35:34 Christopher Kormanyos wrote:
> Hi folks,
> Lost the original message here. Sorry.
> In John's new radix-2 MP back end, names are used for
> common types such as:
> float24_t, float53_t, float113_t.
> In our proposal for floating-point typedef's having
> specified widths, we use names such as:
> float32_t, float64_t, float128_t.
> Both conventions make sense in sensible ways.
> But only one naming convention should be used,
> and it should be used consistently.
> Which one will it be?
I think float32_t, float64_t, float128_t are better since they describe the
size of the type and are aligned with integer typedefs.