Subject: Re: [boost] [PATCH Boost.smart_ptr] Add intrusive_ptr<>::release()
From: Avi Kivity (avi_at_[hidden])
Date: 2013-12-03 03:45:07
On Mon, Dec 2, 2013 at 8:45 PM, Peter Dimov <lists_at_[hidden]> wrote:
> Andrey Semashev wrote:
>> The reset/release pattern is quite established in STL and Boost and I'd
>> prefer not to disturb it. This will only add confusion.
> I agree with Lars and Jonathan, sorry Andrey. Naming the function
> "release" will add confusion even though you might argue that it will
> improve consistency.
I'll rename it to detach() if that's the consensus.