Subject: Re: [boost] Standalone boost::ignore_unused_variable_warning()
From: Peter Dimov (lists_at_[hidden])
Date: 2014-05-19 13:51:56
Antony Polukhin wrote:
> 2014-05-19 19:26 GMT+04:00 Adam Wulkiewicz <adam.wulkiewicz_at_[hidden]>:
> > Or would putting it in boost::utility/BOOST_UTILITY be a better idea?
> boost::utility:: namespace looks reasonable. +1
I don't like it very much. There's nothing particularly utility-specific
about ignore_unused_variable and if/when we decide to move it somewhere
else, we'll have to fix all the uses.
A namespace "utility" shouldn't even exist (except for implementation
Boost list run by bdawes at acm.org, gregod at cs.rpi.edu, cpdaniel at pacbell.net, john at johnmaddock.co.uk