Subject: Re: [boost] date_time -> serialization (Was: spirtit -> serialization)
From: Daniel James (dnljms_at_[hidden])
Date: 2014-06-16 05:08:21
On 15 June 2014 16:42, Andrey Semashev <andrey.semashev_at_[hidden]> wrote:
> On Sun, Jun 15, 2014 at 7:16 PM, Paul A. Bristow
>> Sub-sub-modules sound Very Evil to me.
It's a bad name. Double prefixes are worrying, it suggests
over-nesting. It's also confusing. Since we have to type 'git
submodule' all the time, we're training ourselves to see 'submodule'
as a git term. 'sub-sub-modules' will inevitably sound like nested git
modules, even though that isn't what you mean.
We actually already have a name for the concept, 'sublibs'. It's not
really accurate, but it's better than 'sub-sub-module'.
Boost list run by bdawes at acm.org, gregod at cs.rpi.edu, cpdaniel at pacbell.net, john at johnmaddock.co.uk