Subject: Re: [boost] Boost.DLL formal review is ongoing
From: Klaim - JoÃ«l Lamotte (mjklaim_at_[hidden])
Date: 2015-07-14 07:37:33
On 14 July 2015 at 12:37, Bjorn Reese <breese_at_[hidden]> wrote:
> If we are open to bikeshedding, then I suggest that the library should
> not be named after the subject it operates on (whether we call them
> dynamic link libraries or shared objects), but rather on the
> functionality it provides.
> The purpose of the library is to load and find symbols in the subject,
> so something like Boost.Loader looks like a better alternative to me
> (knowing full well that it does not load arbitrary files.)
In that case, "symbol loader" or "shared library loader" would be more
fitting than "loader" which
could be about other domains.
Personally I don't care much about the name of the library in this case
because almost all the names evoked here seems fine to me,
event the platform-specific evocation ones.
Note: Boost.SharedObject is a name already used by Artyom's (cppcms)
non-boost library which was suggested several time around here but not
Boost list run by bdawes at acm.org, gregod at cs.rpi.edu, cpdaniel at pacbell.net, john at johnmaddock.co.uk