Subject: Re: [boost] Alternative names to Boost.Fit
From: Rob Stewart (rstewart_at_[hidden])
Date: 2016-03-02 11:07:49
On March 2, 2016 9:48:20 AM EST, paul Fultz <pfultz2_at_[hidden]> wrote:
>Boost.Fit is a function utility library, however, the name currently
>have anything with this. I originally chose the name because it started
>F(for function) and it was short and sounded nice. However, there could
>some names(or abbreviations) that more adequately describe the library.
>are some alternatives that are short:
>Of course, I prefer the Boost.FN name.
I'm not sure what the "N" in "FN" is, so I don't see that as a good choice.
>Names like Boost.FP or Boost.FPL
>could imply that it provides full functional constructs whereas
>Boost.Fit does not
>and is mainly focused on functions.
I agree that those are not good.
Boost.Fun would be a fun name and arguably fits (pun intended).
The name doesn't actually need to be short, so Boost.Function Utilities would be fine. The corresponding namespace name would be long, too, but namespace aliases, using directives, and using declarations can mitigate that.
(Sent from my portable computation engine)
Boost list run by bdawes at acm.org, gregod at cs.rpi.edu, cpdaniel at pacbell.net, john at johnmaddock.co.uk