Subject: Re: [boost] Alternative names to Boost.Fit
From: paul Fultz (pfultz2_at_[hidden])
Date: 2016-03-05 14:56:47
> On Saturday, March 5, 2016 1:29 PM, Rob Stewart <rstewart_at_[hidden]> wrote:
> > On March 5, 2016 1:20:27 PM EST, paul Fultz <pfultz2_at_[hidden]> wrote:
>> - Boost.FU
> This one is both a problem and a fun name. As an acronym, it's a problem. I
> won't explain that further. If it were spelled "Fu", it would be
> like "Google Fu" and all of the other variations of kung fu.
> Unfortunately, that meaning disqualifies this option for your library, too,
> since "Boost Fu" would be generic to skill in using Boost libraries.
Yes, Boost.FU would not be my preferred choice. Perhaps, Boost.FUL would be better(but it looks to me like the first three letters of my last name). Ideally, I was preferring Boost.Fn. This is a library for functions. So ideally, I would like it to be called function or functions, but that name has already been taken by "any_function"(AKA boost::function). This is why I was leaning towards an abbreviation of function instead(ie Fn).
With longer names, I would prefer acronyms:
* Boost.FL - Function Library
* Boost.FUL - Function Utility Library
* Boost.HOF - Higher-order Functions
* Boost.FCL - Function Combinator Library
* Boost.PEF(my initials) - Programming Enhancements for Functions
For simple short names, there is:
* Boost.Combinator - however, the library is more than combinators
* Boost.Curry - the library is more than currying.
My preferred choice:
* Boost.Fn - A library for functions