Boost logo

Boost :

Subject: Re: [boost] [review][Fit] Review of Fit starts today : September 8 - September 17
From: Hans Dembinski (hans.dembinski_at_[hidden])
Date: 2017-09-18 10:10:16

> On 15. Sep 2017, at 20:45, Robert Ramey via Boost <boost_at_[hidden]> wrote:
> I don't like names like Fit which give no helpful information. But I've lost that battle before so I won't belabor this any more.

I would like to join the chorus of people who don't like the name "Fit". Please - please - consider changing this.

"Fit", what does it mean? Is it an acronym (perhaps for function interface toolkit??)? Was the library written in a "fit" of rage over the lack of proper tools? Is the library in particular good health, perhaps? The documentation does not tell us, but even if it would, a longer, more descriptive name would be helpful.

In my personal professional context, a "fit" refers to code that adapts a statistical model to stochastic data by minimising a cost function, which somehow measures the closeness of the model and the data. Googling "c++ fit library" yields links to Boost.Fit, but the first other hits are related to such optimisation libraries (this is not because of my personal Google search bubble, I used a private browser session). This as another hint that the name "Fit" is misleading.

If I may suggest a name: I like description on github "function utility library". So what about "Function Utilities", which is quite descriptive. On the Boost library page it would be inserted next to "Function" and "Function Types", which - ironically - seems quite "fit"ting.

PS: Googling "fit library" yields such curious results as "Fashion Institute of Technology" in NYC and the "Florida Institute of Technology" (both have a library). :)

Best regards,

Boost list run by bdawes at, gregod at, cpdaniel at, john at