Boost logo

Boost :

Subject: Re: [boost] [review] The review of Boost.DoubleEnded starts today: September 21 - September 30
From: degski (degski_at_[hidden])
Date: 2017-10-08 06:40:01


On 8 October 2017 at 00:18, Steven Watanabe via Boost <boost_at_[hidden]
> wrote:

> deque = double ended queue
> devector = double ended vector
> veque = vector queue?
>

More Sunday-morning bikeshedding (TM) then :-], on special request.

The 'double-ended' in double-ended-queue (deque) in my view is already
problematic. Any finite 2-dimensional object has 2 ends (including a
std::vector). 'double ended' adds no information. I know it's got two ends,
because I know it's 2-dimensional and finite.

A std::deque *is* just a queue, and doesn't specify its' use cases.
std::queue should be a std::fifo_queue, and then a std::stack would be a
std::lifo_queue. std::priority_queue already fits in nicely in this scheme,
where the bit in the name before the underscore stipulates the 'mechanics'
of that particular queue. If one coud only change the world! :-)

That's how I get to veque, de::devector is a queue (in the sense of
std::deque, a queue in my view, see above) with most properties of a
vector (contiguity/relocation etc...).

So yes, a veque is a vector-queue, to answer your question.

degski

-- 
"*Ihre sogenannte Religion wirkt bloß wie ein Opiat reizend, betäubend,
Schmerzen aus Schwäche stillend.*" - Novalis 1798

Boost list run by bdawes at acm.org, gregod at cs.rpi.edu, cpdaniel at pacbell.net, john at johnmaddock.co.uk