Subject: [boost] Boost Python library suffix change
From: Stefan Seefeld (stefan_at_[hidden])
Date: 2018-02-07 02:20:32
I'm proposing a naming change that affects all libraries that use the
`python.jam` build logic, i.e. Boost.Python, as well as libraries
providing Python bindings (as far as I can tell, this is only Boost.MPI,
but perhaps I'm missing some).
At present, the Boost.Python build logic produces a library named
"boost_python", if built with Python2, and "boost_python3", if built
with Python3. I'd like to change that so the actual Python version
suffix (e.g. "27" for Python 2.7) is being used. Not only would this
simplify / unify naming conventions, it also allows users to collocate
libraries compiled against multiple Python versions more easily.
While I could apply this change to Boost.Python only, it seems more
natural to patch Boost.Build itself, in which case any library whose
build logic uses `python.jam` would also be concerned. Again, as far as
I can tell, this only concerns the Boost.MPI Python bindings, but
perhaps I'm missing some. So if you are concerned, please speak up, so
we can discuss any necessary changes.
-- ...ich hab' noch einen Koffer in Berlin...