Boost logo

Boost :

Subject: Re: [boost] [range] #11202: boost.sort header conflicts with boost.range header
From: Andrey Semashev (andrey.semashev_at_[hidden])
Date: 2018-09-03 09:22:15

On 09/03/18 11:42, Gareth Sylvester-Bradley via Boost wrote:
> At 2 Sep 2018 18:48, Edward Diener via Boost wrote:
>> On 9/2/2018 10:09 AM, Mathias Gaunard via Boost wrote:
>>> On 2 September 2018 at 03:21, Steven Ross via Boost <boost_at_[hidden]> wrote:
>>>>> I think it is a bad idea to make an exception for boost::range::sort
>>>>> when all the other range algorithms are directly in boost:: .
>>>> It's not pretty, but it sounds reasonable to me. Do you have a
>>>> counterproposal?
>>> Rename the "sort" library to something else.
>>> "sortlib" is very bad, but other names could be found.
>> I was just suggesting a change in the namespace name to something else.
>> It can still be called the sort library, even if the namespace is not
>> boost::sort.
> Would it be appropriate to adopt the strategy of Boost.Tuple, whose namespace is boost::tuples, and use boost::sorts as the library namespace?
> The naming consistency guidelines say:
> * The library's primary namespace (in parent ::boost) is given that same name, except when there's a component with that name (e.g., boost::tuple), in which case the namespace name is pluralized. For example, ::boost::filesystem.
> That's maybe not quite the case here, but it's not horrible!

I'm not a native speaker, but I don't think "sort", in the meaning the
library puts in it, has a plural form as it is a verb. "Sorting" might
be an alternative.

Boost list run by bdawes at, gregod at, cpdaniel at, john at