Subject: Re: [boost] [range] #11202: boost.sort header conflicts with boost.range header
From: Groke, Paul (paul.groke_at_[hidden])
Date: 2018-09-03 09:53:35
> -----Original Message-----
> From: Boost <boost-bounces_at_[hidden]> On Behalf Of Andrey
> Semashev via Boost
> Sent: Montag, 3. September 2018 11:22
> Subject: Re: [boost] [range] #11202: boost.sort header conflicts with
> boost.range header
> I'm not a native speaker, but I don't think "sort", in the meaning the library
> puts in it, has a plural form as it is a verb. "Sorting" might be an alternative.
Boost.Move has a similar situation and uses namespace boost::movelib.
Therefor I think the originally suggestion, boost::sortlib, isn't such a bad idea. I don't really *like* the name, but it would be consistent with Boost.Move.
That aside, I think boost::sorting is a good name.