Boost logo

Boost :

From: Vinnie Falco (vinnie.falco_at_[hidden])
Date: 2019-09-12 16:06:25

I have collected the feedback into individual issues for discussion
and to track the progress of changes:

On Thu, Sep 12, 2019 at 2:38 AM Dominique Devienne via Boost
<boost_at_[hidden]> wrote:
> > Interestingly, it to be named fixed_capacity_vector, renamed in revision 2
> >
> Which is a much better name IMHO. Longer, sure, but now it's clear and
> unambiguous. --DD

On Thu, Sep 12, 2019 at 4:29 AM degski via Boost <boost_at_[hidden]> wrote:
> ...the class should be made constexpr.

On Thu, Sep 12, 2019 at 6:19 AM Mike via Boost <boost_at_[hidden]> wrote:
> ...make the string trivially copyable (simply copy the whole
> storage, not just the bytes actually containing the string).

On Thu, Sep 12, 2019 at 6:19 AM Mike via Boost <boost_at_[hidden]> wrote:
> ...conditionally enable support for std::string_view in c++17
> (implicit conversion to and explicit construction from string_view)

On Thu, Sep 12, 2019 at 7:29 AM Bjorn Reese via Boost
<boost_at_[hidden]> wrote:
> For the string_view to bikeshedding_string conversion I would prefer a
> temmplated constructor that takes a container (a Range concept to be
> precise.)

On Tue, Sep 10, 2019 at 6:15 AM Phil Endecott via Boost
<boost_at_[hidden]> wrote:
> ...if small size is an aim (and I think it
> should be), we can do better; when N < 256, use a uint8_t for the
> size. In fact, use boost::integer::uint_t< log2<N> >::least and
> get an optimal type for the size.

Feel free to add to these issues or to create new ones (or discuss on the list)


Boost list run by bdawes at, gregod at, cpdaniel at, john at