Boost logo

Boost :

From: Seth (bugs_at_[hidden])
Date: 2022-08-24 21:44:08

On Wed, Aug 24, 2022, at 9:02 PM, Vinnie Falco via Boost wrote:
> On Wed, Aug 24, 2022 at 10:16 AM Zach Laine
> <whatwasthataddress_at_[hidden]> wrote:
>> For this case, I definitely prefer ref to view.
> \phew... progress :)
> So, to be explicit - does everyone agree that this set of container
> names is currently the best alternative thus far?

Even though this is solliciting to become design-by-committee (there will never be full consensus) I will go on record that I think the `_ref`/`_cref` suffixes are reasonable to me. At least they're relatively short and consistent (ref/cref is a closer pair than mutable/const)

In my code I would ironically be tempted to use auto more to hide the crufty names because I know they're views anyways. Which is probably why I don't mind the old names. In terms of minimizing surprise these names do a better job.

Boost list run by bdawes at, gregod at, cpdaniel at, john at