Boost logo

Boost-Build :

Subject: Re: [Boost-build] custom bcp build no longer finds boost-build.jam in 1.57.0
From: John Maddock (boost.regex_at_[hidden])
Date: 2014-12-02 12:42:33

>> However, step 5 now fails to find boost-build.jam in the latest
>> version, boost 1.57.0. I tried to look over similar topics on the
>> mailing
>> list, but they don't seem to have a suitable solution for my case.
>> Also, I tried using:
>> -sBOOST_ROOT=<new directory>
>> and the BOOST_ROOT environment variable, but got the same error message.
> Hi Kevin,
> what's the error message exactly? Would the following work:
> <original-src>/b2 -sBOOST_BUILD_PATH=<original-src>/tools/build
> [further options]

Kevin, I have a fix for this, which is partly in develop but not yet

Vladimir, I have one remaining issue, after copying all the missing
build files (or using develop bcp) I get (the starting position is a
"./dist/bin/bcp regex build ../test"):

M:/data/boost/test/tools/build/src/build\project.jam:262: in
find-jamfile from module project
error: Unable to load Jamfile.
error: Could not find a Jamfile in directory 'tools/inspect/build'.
error: Attempted to find it with pattern '[Bb]uild.jam [Jj]amfile.v2
[Jj]amfile [Jj]amfile.jam'.
error: Please consult the documentation at ''.
M:/data/boost/test/tools/build/src/build\project.jam:280: in
load-jamfile from module project
M:/data/boost/test/tools/build/src/build\project.jam:64: in load from
module project
M:/data/boost/test/tools/build/src/build\project.jam:89: in
load-used-projects from module project
M:/data/boost/test/tools/build/src/build\project.jam:75: in load from
module project
M:/data/boost/test/tools/build/src/build\project.jam:145: in
project.find from module project
M:/data/boost/test/tools/build/src\build-system.jam:535: in load from
module build-system
M:\data\boost\test\tools\build\src/kernel\modules.jam:289: in import
from module modules
M:\data\boost\test\tools\build\src/kernel/bootstrap.jam:139: in
boost-build from module
M:\data\boost\test\boost-build.jam:17: in module scope from module

Why? What on earth in the build system is pulling in inspect? I can
fix that by copying that specific Jamfile, which leads to an error
complaining about libs/tools/wave/tool/build/Jamfile.v2 being missing.
If I copy that file as well, then everything seems to more or less work.

I can fix bcp by adding a manual dependency from to those 2
files, but that seems crazy. Any ideas?

Thanks, John.

Boost-Build list run by bdawes at, david.abrahams at, gregod at, cpdaniel at, john at