From: Debabrata Mandal (mandaldebabrata123_at_[hidden])
Date: 2020-05-25 09:10:52
No need to reply to this email, I will send another mail with the link to
the first PR. We can discuss issues at that time.
Generally, it's looking good, but for detailed review
> I'd prefer if there is a first PR, whenever you are ready.
> Yes, I will start with one file at a time and update the GitHub project
imgHist - please don't use CamelCase names, but prefer Boost and
> C++ standard library naming, lower_case_name.
> I think the name `histogram(...)` is a better name.
> I agree.
I'm also not convinced about the parameter bool accumulate.
> Instead, I'd consider controlling normal (ordinary) and cumulative
> modes via an enum.
> Alternative could be two functions: histogram and cumulative_histogram.
> A slight clarification, accumulate is not for cumulative histogram, it is
to clarify whether we should clear the container or not. It does complicate
the idea so I will drop it for now.
I am adding cumulative histogram separately also.
Boost list run by Boost-Gil-Owners