Boost logo

Boost Users :

From: Felipe Magno de Almeida (felipe.m.almeida_at_[hidden])
Date: 2006-01-15 14:16:29

On 15 Jan 2006 14:53:00 +0000, Jens Theisen <jens-theisen_at_[hidden]> wrote:


> So it's purpose is to abbreviate a const_cast. Still useful.

It's more readable and documents better the code too. Since const_cast
can take consts away, but const_ only makes it const, and easier to
use in generic code, since you dont need to rewrite the instance's
type to be able to add const to it.

> Jens

Felipe Magno de Almeida

Boost-users list run by williamkempf at, kalb at, bjorn.karlsson at, gregod at, wekempf at