Boost Users :
From: Eric Niebler (eric_at_[hidden])
Date: 2006-01-15 17:25:46
Felipe Magno de Almeida wrote:
> On 15 Jan 2006 14:53:00 +0000, Jens Theisen <jens-theisen_at_[hidden]> wrote:
>>So it's purpose is to abbreviate a const_cast. Still useful.
> It's more readable and documents better the code too. Since const_cast
> can take consts away, but const_ only makes it const
Then perhaps it should be called "add_const".
-- Eric Niebler Boost Consulting www.boost-consulting.com
Boost-users list run by williamkempf at hotmail.com, kalb at libertysoft.com, bjorn.karlsson at readsoft.com, gregod at cs.rpi.edu, wekempf at cox.net