Subject: [ggl] namespace renaming
From: Barend Gehrels (Barend.Gehrels)
Date: 2009-12-03 07:36:40
>> So I propose namespace shape for the neutrally-named collection of shapes.
>> We then get:
>> boost::geometry::shape::point<...> // as we have it now in boost::geometry
>> boost::geometry::shape::polygon<...> // as we have it now in
> It's better than "geometry" indeed. However maybe an even better name
> would be "model", since those geometries model the concepts GGL
> defines. It would state more clearly that those shapes are not mere
> shapes but are also examples of models for our concepts.
I agree that model is a better name. Very good.
So that is the new proposal :-)
-------------- next part --------------
An HTML attachment was scrubbed...
Geometry list run by mateusz at loskot.net