Subject: Re: [geometry] [Spatial Index] bug & question
From: Barend Gehrels (barend_at_[hidden])
Date: 2013-06-19 12:56:46
On 19-6-2013 16:48, Adam Wulkiewicz wrote:
> TONGARI wrote:
>> But I don't think this could be implemented in a really generic way for
>> Spatial Index, so I think a 'contains' (and 'covers'?) addition would
>> just be fine.
> I like this solution, it's simple and meaningful. But this only makes
> sense if those names aren't used in Boost.Geometry for something
> different than boolean operation. So, I guess we must wait for Barend
> with this.
Contains is perfect. It is reserved for exactly this function. It is
(about) the reverse of within. Also covers is fine, which is (about) the
reverse of covered_by. We plan to support them in Boost.Geometry too.
And a blog of "Dr JTS" explaining subtleties between the definitions
Geometry list run by mateusz at loskot.net