Boost logo

Ublas :

Subject: Re: [ublas] size1 and size2
From: Marco Guazzone (marco.guazzone_at_[hidden])
Date: 2009-09-10 10:36:06


On Thu, Sep 10, 2009 at 12:39 PM, Marco Guazzone
<marco.guazzone_at_[hidden]> wrote:
> On Thu, Sep 10, 2009 at 10:16 AM, Rutger ter Borg <rutger_at_[hidden]> wrote:
>>
>> I would vote for col_size and row_size, or column_size and row_size. Having
>> a "size" in the name is more consistent with STL.
>>
>
> Good choice, maybe "cols_size" and "rows_size"?
>

The same should apply to iterators. Something like:

iterator1 ==> row_iterator
iterator2 ==> column_iterator
reverse_iterator1 ==> reverse_row_iterator
// ...

matrix::begin1() ==> matrix::row_begin()
matrix::begin2() ==> matrix::column_begin()
matrix::find1() ==> matrix::row_find()
// ...

iterator1::index1() ==> row_iterator::row_index()
iterator1::index2() ==> row_iterator::column_index()
// ...

Cheers!

-- Marco