Boost logo

Ublas :

Subject: Re: [ublas] lapack bindings - linker errors in windows but not linux
From: P.L.W. Man (plwm2_at_[hidden])
Date: 2010-04-21 07:07:13


Well, the linux i used are installed on various cluster nodes maintained by
someone who knows about that stuff. So I assume he installed atlas and
lapack 'properly'. As it turns out, on my local windows XP machine, I
installed atlas and lapack via cygwin myself, so the probability that
something has gone wrong is possibly quite high. You're pretty much right
that I expect to use them out of the box in VC9.0 and g++.

As to the links that you have requested, they are:



As to the DBIND_FORTRAN_LOWERCASE_UNDERSCORE, i tried with and without this
include definition.

Thank you for your fast response!


On Apr 21 2010, Thomas Klimpel wrote:

>P.L.W. Man wrote:
>> I have a problem very similar to msg#00005
>What do you mean by msg#00005? Can you provide a link instead?
>> - I am using the numeric bindings (v1) for lapack/atlas etc.
>> I'm pretty much a newbie to programming. My C++ program compiles
>> (and links) perfectly on Fedora 12, using g++.
> Since you say you are a programming newbie, I guess that you installed
> lapack/atlas etc. with the normal package manager so that they worked
> just right out of the box.
>> However, when I try to compile on windows (either using
>> Microsoft VS 9.0 or compiling directly using g++ in cygwin), it
>> compiles perfectly, but the following linker errors result:
> I guess you installed lapack/atlas etc. by some method that appeared
> reasonable to you, and now expect that we exactly know what you have
> done. I can only guess that you installed them via cygwin, and now expect
> them to work out of the box with both VC9 and g++. Is this assumption
> correct?
>> The msg#00014 seems to indicate that the problem was due to something
>> called name mangling but tantalisingly does not provide the solution.
>What do you mean by msg#00014? Can you provide a link instead?
>> Having read (a very little) about name mangling, i tried the following
>> commands on the object files created for each of the three methods of
>> compiling:
> On windows, you normally have to compile with
> -DBIND_FORTRAN_LOWERCASE_UNDERSCORE, but you say that you already tried
> that.
>ublas mailing list
>Sent to: plwm2_at_[hidden]