Boost logo

Boost :

From: Dave Abrahams (abrahams_at_[hidden])
Date: 2000-01-13 10:25:32

>> * The name should capture all or some of the following properties:
>> insertion, removal, encapsulation of an ordering policy.
> Yes. The absence of that third property was the reason for my prior
> question about what the concept was. From the response, I did
> manage to deduce it and conclude that dispenser was the only name
> suggested that even hinted at that most important property. I think
> that I qualify as an ignorant documentation reader. ;)

How about "GenericQueue"? It's really too bad that the standard chose queue
already for that strange concept it contains. I think we're trying to
capture fifo queue, lifo queue, priority_queue, etc.

Boost list run by bdawes at, gregod at, cpdaniel at, john at