Boost logo

Boost :

From: Ed Brey (brey_at_[hidden])
Date: 2000-07-05 15:10:45

From: "Mark Rodgers" <mark.rodgers_at_[hidden]>
> OK then, what do you think of a boost/algorithm.hpp that looks something
> like this:

Your implementation goes as far as is possible, and I think will work quite
nicely. I have two remaining, small suggestions:

1. Name it boost/detail/algorithm.hpp, since this is not a library we expose
directly to the end user. I see the purpose of this file as making it easy
to write boost code that relies on functions and members with the name min
and max, whereas providing a workarounds to API header file snafus for their
own sake is beyond the scope of boost. Of course, if an end user wants to
make use of the file for a non-boost-related reason, that is fine, but then
he is "digging into the details".

Of course, by this logic, shouldn't config.hpp be under detail, also?

2. Include a comment indicating why this workaround wasn't put into
config.hpp, namely that the template functions aren't a 100% substitute for
the macros and the potential for ODR violation.

Boost list run by bdawes at, gregod at, cpdaniel at, john at