From: David Abrahams (abrahams_at_[hidden])
Date: 2000-12-30 09:05:16
----- Original Message -----
From: "Aleksey Gurtovoy" <alexy_at_[hidden]>
Sent: Saturday, December 30, 2000 7:00 AM
Subject: RE: [boost] Review: Iterator adaptors
> Jeremy Siek wrote:
> > Old naming issue: the standard LessThanComparable requirement only
> > requires operator<. Therefore the less_than_comparable operator helper
> > does not help one create a model of LessThanComparable. Instead it
> > the SGI STL version of LessThanComparable, which in the concept checking
> > library I refer to as the Comparable concept.
> The same about 'equality_comparable' class template. As I wrote a little
> ago (http://www.egroups.com/message/boost/7697), these two templates are
> only ones which do not match the proposed summary of template names
> (which we haven't discussed yet). IMO, we should rename them (for me
> 'comparable' still seems as a good replacement for 'less_than_comparable';
> good ideas about another one, though), and add the summary notes to docs.
How about StrictWeakOrdered or StrictWeakComparable?
My only real problem with plain "Comparable" is that it's overgeneral. That
is, if you can ask "a == b?" you have compared a and b, meaning that they
were comparable. The concept doesn't cover equality comparison, though.
Boost list run by bdawes at acm.org, gregod at cs.rpi.edu, cpdaniel at pacbell.net, john at johnmaddock.co.uk