Boost logo

Boost :

From: Howard Hinnant (hinnant_at_[hidden])
Date: 2001-11-26 16:07:41

On Monday, November 26, 2001, at 03:30 PM, Andrei Alexandrescu wrote:

> From: "David Abrahams" <david.abrahams_at_[hidden]>
>> BTW, isn't "identity" a much better name than "type2type"?
> Identity sounds great, I'll make that change unless there is a lot of
> opposition.

identity sends up a red flag with me because of:

Today they are in different namespaces so who cares. But I think both
are realistic candidates for standardization.

Otoh, SGI's identity is practically a superset of Loki::Type2Type. What
about adopting SGI's identity?


Boost list run by bdawes at, gregod at, cpdaniel at, john at