From: Dave Harris (brangdon_at_[hidden])
Date: 2005-05-05 07:27:38
gennadiy.rozental_at_[hidden] (Gennadiy Rozental) wrote (abridged):
> The only two negative reviews based their rejection on principle:
> "Macros are evil and so should not be used". While this maybe
> interesting point in itself, as I see things now, boost practice
> supports using macros where necessary and macro nature of the tool
> could not be a compelling enough reason to reject the submission.
For the record, my review was negative and was not based on that
principle. I agree with the boost policy of using macros where necessary.
I rejected it because it is an overly complex solution to a simple
> While there were not so many specific issues discovered during
> review, I would like to list couple:
What about the name? Shouldn't it be "BOOST_FOR_EACH"?
-- Dave Harris, Nottingham, UK.
Boost list run by bdawes at acm.org, gregod at cs.rpi.edu, cpdaniel at pacbell.net, john at johnmaddock.co.uk