Boost logo

Boost :

From: Steven Watanabe (watanabesj_at_[hidden])
Date: 2008-02-13 10:47:51


Zach Laine wrote:
>> How about:
>> boost::control_flow
>> boost::switch_case
>> ?
>> (I don't much like either of those, but maybe they'll inspire somebody
>> else).
> Well, usually such compile-time versions of familair runtime
> constructs are called static_*, so how about static_switch?

Well... It's not really a compile time version of a switch statement.

Thanks for the help. I think the best suggestions were control/control_flow
although I'm still not entirely happy with them.

In Christ,
Steven Watanabe

Boost list run by bdawes at, gregod at, cpdaniel at, john at