Boost logo

Boost :

Subject: Re: [boost] [mp_int] new release
From: Scott McMurray ([hidden])
Date: 2008-10-08 11:10:35

On Wed, Oct 8, 2008 at 11:01, Brandon Kohn <blkohn_at_[hidden]> wrote:
> --------------------------------------------------
> From: "Mathias Gaunard" <mathias.gaunard_at_[hidden]>
> Sent: Monday, October 06, 2008 5:50 PM
> To: <boost_at_[hidden]>
> Subject: Re: [boost] [mp_int] new release
>> Kevin Sopp wrote:
>>> I made a new release of my multiprecision integer library
>> I personally find the words arbitrary precision or multiprecision
>> ambiguous.
>> I never know which one means that the numbers grow as needed and which
>> ones means that it can work with any size, but fixed (which is useful to
>> simulating hardware).
> I have this same issue. From my tests I suspect his grows arbitrarily. I
> would propose a name change to reflect that. I'm sure this has been
> discussed before. big_int seems popular if a bit crude. Assuming it is
> arbitrary, arbitrary_precision_int? (perhaps convenience typedefs?) I tend
> to prefer descriptive names to abbreviations; though I concede I may be in
> the minority.

I'm not a fan of that one, since LLVM has an "APInt" class which
represents a fixed, but arbitrary, precision integer.

How about unbounded_int? It fits nicely with the is_bounded in numeric_limits.

~ Scott

Boost list run by bdawes at, gregod at, cpdaniel at, john at