Boost logo

Boost :

Subject: Re: [boost] [multiprecision] Are these types suitable asnumerictypes for unit tests?
From: Christopher Kormanyos (e_float_at_[hidden])
Date: 2013-06-09 08:42:14

>>The names "enable_if" and "disable_if" are ambiguous
>>because they are present in the namespace "boost"
>>as well as in "boost::unit_test::decorator".

> Oh *&^%^&*!

>>Modifying <boost/multiprecision/number.hpp> by
>>replacing enable_if with boost::enable_if, etc. resolves
>>the ambiguity.

>I realise that fix is only a search and replace away... but the code is
>obfuscated enough already by all the enable_if stuff without having to use
>fully::qualified::names everywhere.

>I've filed a bug report:

>Can we just use the separately compiled boost.test in the mean time?

Yes, of course. I agree. Let's pace ourselves, you know, get
1.54 out. When the dust settles later on, we can search-and-replace
away in trunk.

I will disseminate this information to our GSoC student
who is active in this area.

Thank you again.

Sincerely, Chris.

Boost list run by bdawes at, gregod at, cpdaniel at, john at