Boost logo

Boost :

From: Boris Kolpackov (boris_at_[hidden])
Date: 2021-11-30 08:57:20

Oliver Kowalke <oliver.kowalke_at_[hidden]> writes:

> Am Mo., 29. Nov. 2021 um 15:54 Uhr schrieb Boris Kolpackov <
> boris_at_[hidden]>:
> > FWIW (and I may be out of context), but "spawn" seems like a
> > too generic of a name. I, for example, thought this is about
> > posix_spawn(). Maybe call it spawn_fiber or some such?
> >
> boost.asio named the function spawn() - boost.spawn named it spawn_fiber()

Sorry, looks I wasn't clear enough: I am talking about the library
name being too generic: Boost.Spawn can mean spawning all kinds of
things (processes, threads, fibers, etc). The fact that you called
the function spawn_fiber() in a sense confirms this.

Boost list run by bdawes at, gregod at, cpdaniel at, john at