Boost logo

Boost Users :

Subject: Re: [Boost-users] Problem using Boost regex
From: John Emmas (johne53_at_[hidden])
Date: 2009-12-09 12:26:16

----- Original Message -----
From: "John Maddock" <john_at_[hidden]>
>>> basically you want to invoke:
>>> bjam --with-regex --build-type=complete stage
>>> [ ... ]
>> Thanks. I tried that but bjam can't find "windows.h". What do I need to
>> configure / edit to add the appropriate include path?
> Nothing to do with bjam: that would be the Visual C++ command line tool
> not being configured correctly - try adding the include path to the
> Windows SDK headers to your vcvars32.bat file, you might have to update
> the library search path in there as well.
Okay, I just got around to doing that. AFAICT bjam actually
calls'VC\vcvarsall.bat', passing it the parameter "x86". This in turn,
calls 'VC\bin\vcvars32.bat'. Unfortunately, bjam directs the output of that
call to nul - so I can't tell whether vcvars.bat is executing correctly.
But I assume not, because I still get the error 'Cannot open windows.h'.
How do I stop bjam from directing the batch file output to nul?


Boost-users list run by williamkempf at, kalb at, bjorn.karlsson at, gregod at, wekempf at