Boost logo

Boost :

From: Rob Stewart (stewart_at_[hidden])
Date: 2005-08-31 10:36:33

From: David Abrahams <dave_at_[hidden]>
> Aleksey Gurtovoy <agurtovoy_at_[hidden]> writes:
> >
> > I'd go with 'key_count' for the latter, but otherwise I agree with the
> > analysis.
> "count_key" sounds more natural to me, FWIW.

I'd say it isn't a matter of whether it sounds "natural" but that
this is an algorithm and should be described by a verb or verbal
phrase. IOW, I agree that "count_key" is better.

Rob Stewart                           stewart_at_[hidden]
Software Engineer           
Susquehanna International Group, LLP  using std::disclaimer;

Boost list run by bdawes at, gregod at, cpdaniel at, john at